Topic: Decreasing CPU Usage?

This topic contains 7 replies, has 3 voices, and was last updated by  DragonDope 3 years, 9 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • #31920

    DragonDope
    Participant

    Hey, interested party here, just wanted to know if there’s any tricks (besides bouncing the living crap out of everything, and enabling plugin multi-threading) for reducing CPU? I prepared a fairly simple 4 bar diddly, and at idle it’s sitting at about 15%-20%, which isn’t much honestly. The only worry is that I have more complex pieces that can play on FL Studio that use less CPU (looking at one now that averages about maybe 10%-15%, and that’s with Podium open too), and I feel that I might not be able to expand my songs too much at this rate.

    I have an i7 6700k CPU (4 GHz), and 16GB of RAM. I’m probably worrying needlessly, but I’d still like to see if there are any tips to be had on this topic.

    Also, this is the demo version, if that helps.

    Thanks in advance for replying!

    #31930

    Hermu
    Participant

    limitations of Podium Free compared to the commercial version:

    – MIDI interface setup is limited to one input and one output.
    – 64-bit mixer engine option is disabled.
    – Plugin multiprocessing is disabled.
    – ReWire is disabled.
    – Surround-sound playback is disabled.

    The disabled plugin multiprocessing option means that only one CPU core will be used when processing plugins. If you have a dual-core CPU you will be able to use 50% of your available CPU power before the Podium CPU indicator overloads. Podium Free still uses all available CPU cores for various background tasks such as audio file disk streaming.

    These limitations may change in newer releases of Podium Free, depending on the future development of Podium.

    • This reply was modified 3 years, 9 months ago by  Hermu.
    #31932

    nicholas.h
    Participant

    Try the full Podium Demo for a more even comparison. Also, you mention running FL side-by-side, which makes me wonder if you have an equivalent ASIO driver selected in Podium’s Setup menu > Audio/MIDI > Audio I/O tab. (Windows MME is less performant.)

    #31933

    DragonDope
    Participant

    @hermu Thanks for the advice, but I think you missed the bit where I said I was using the demo verison.

    @nicholas.h I am, and I do have Windows MME selected as of now. That’s only because ASIO4ALL doesn’t emit sound, and Fruity ASIO crashes it immediately (usually, for whatever reason it’s cooperating now)

    #31934

    Hermu
    Participant

    i never had any problems with ASIO4ALL to get it work on any systems.
    it seems, you have a audio driver problem and i would suggest first to install latest audio driver.
    you should also install latest version of ASIO4ALL and refer documentation if you have problems to get it work.
    as nicholas.h postet, to get a performant system you should not use MME and you should also check, that Setup->Preferences->Plugins->Enable plugin Multiprocessing is ENABLED.

    • This reply was modified 3 years, 9 months ago by  Hermu.
    • This reply was modified 3 years, 9 months ago by  Hermu.
    #31943

    DragonDope
    Participant

    Ok, so I got ASIO4ALL to work, and performance is even worse somehow. On one particular sequence, CPU usage jumps up to 40%, but in MME, it only goes to 20%

    #31946

    Hermu
    Participant

    Have you also tried ASIO4ALL with increased buffer size?
    default is 512 samples and you could try to increase to 1024 or 2048 samples

    #31947

    DragonDope
    Participant

    Yea, now that’s working a lot better. Getting peaks at about 20% now

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

© 2020 Zynewave