Topic: Real fades

Viewing 10 posts - 1 through 10 (of 10 total)
  • #1685

    I struggle since a long time on trying to obtain real fades in Podium, but it seems to be impossible.
    Either with the volume envelopes or with the fades, there is always an abrupt step between silence and sound.
    Most of the time it can be masked with other sounds, but there are some times where it is not possible and it is really bad with reverbs ends.
    It doesn’t happen with other hosts.
    Please, can you verify and possibly correct this ?
    Thanks a lot.


    Sounds like Frits has set up the minimum volume to infinite (silence) and then have it start at something like maybe -60dB or -48dB? While it’s undoubtedly more desirable built in, you could use a volume plugin where it counts, one that goes down to -100dB…


    The track volume and the event volume are limited to -48 dB (and I whish it could go lower !), but I suppose that it doesn’t apply to fades and envelopes.


    Can you provide an example of how to reproduce this problem?


    Here is a test sound :

    Description (I hope that you will understand me…) :
    – in all audio softwares this sound disappear progressively, but in Podium something can be heard until the end
    – if I do a fade out in Podium it doesn’t change anything
    – if I draw a fade out with a volume envelope it doesn’t change anything
    – the perceived sound volume (last second) is the same when the track volume is set to +12 or – 48, but the sound disappear when it is set to Off
    It seems that Podium make it hear at a fix level when there is some samples that have not a 0 amplitude.
    The tests are made of course without any plugin, in the same computer(s), same ASIO device(s) and same speakers (and same ears and brain too !).

    Happily, it is not rendered, it happens only in playback. But it makes doing fades really difficult because in that cases I can’t believe what I hear.

    Do you note the same thing ???


    I imported your fadeout.wav into a blank arrangement, set to 48000 samplerate, no plugins, and no gain/pan changes.

    If I zoom in on the fadeout.wav I see it gradually fades out until the last 0.08 second of the file which is all zeroes.

    I can’t see/hear any problems. If I start playback halfway through the sound I don’t hear anything. The peak hold indicators in Podium show -88 dB and that is the same value that my RME mixer control panel shows. If I turn up the volume of my headphones I can hear the decay, but it fades out nicely to silence. Please verify what your master track peak hold values show and check if they match the reported output by your audio card control panel/mixer.


    Further investigations :
    – Podium with ASIO4All driver : what I have described. Podium is the only app that shows this problem (also tested with Reaper, Soundforge, Acoustica, Wavosaur, Audition, Samplitude, Bidule, Audiomulch, Usine, with the same setup)
    – Podium with MME driver : it’s OK, the fade is what it must be (what you describe)
    – Podium with Rearoute ASIO sent to Reaper, which uses ASIO4All : same problem that what I have described PLUS a click each time a sound starts or ends with silence. If I record what Reaper receives and then play it back, it shows that the “sustained fades” and the clicks are recorded. If I render the same section In Podium and then play it in Reaper, it is clean (no sustain and no start/stop clicks). This proves that they are created by Podium when it plays back, with ASIO4All (sustain only) and RearouteASIO (sustain + clicks). Choosing 32 bits float or integer for the driver makes no difference.
    Other apps linked to Reaper with Rearoute don’t show the problem.

    So it seems definitely to have something to deal with how Podium plays with some ASIO drivers.
    It sounds like if there is a “silence” dection that makes it send signal only if there is some samples.

    Alas, I cannot use my RME because I have actually no more computer with a PCI card…
    Can you try with ASIO4All and perhaps also with Rearoute ?
    I will understand that you have other priorities, but it is a real problem for me, and I have not found any workaround.


    Which ASIO4ALL version?

    What ASIO buffer size have you set ASIO4ALL to use?

    Try if you can set it to a number divisible by 16 (256, 512, 1024 or similar), and check if this gets rid of the noise problem.


    version 2.8

    ASIO4All is set to 512 samples for every app.
    Podium shows always a different value : 512 > 784, 1024 > 1296, 256 > 528.
    It doesn’t change anything.


    I have now tested with ASIO4ALL v2.8, and I can find no problems. I tried with various buffer sizes, and with both my RME interface and the internal PC soundcard.

    Have you tried the latest A4A 2.9 beta?

    You mentioned that you were able to record the static Podium outputs through Reaper. Can you post/send a wav of that?

    It will also be a help if you can email me the project file you use to record the static problem.

    Also, please post/send the Podium interface report for your ASIO4ALL settings.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.
© 2021 Zynewave