Topic: VST3 support?

This topic contains 5 replies, has 5 voices, and was last updated by  tomx2188 1 month, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • #38603

    4mica
    Participant

    Normally it wouldn’t be an issue, but due to Steinberg’s efforts I am starting to see more and more new developers having only VST3 versions available. I could get Metaplugin but that costs. See this in Podium’s future? Thanks—

    #40633

    tomx2188
    Participant

    Yeah, native VST3 support would be great!

    For now I am using a free plugin called Kushview Element to wrap any VST3 I want to use. It runs fine inside Podium, so this solution works reasonably well but is a bit cumbersome.

    #40636

    Zynewave
    Keymaster

    VST3 support is something I will work on in the future. Are there any current popular plugins that are available only as VST3 and not VST2?

    #40639

    AOS74
    Participant

    Melodyne 5 is VST3 only.

    #40642

    kingtubby
    Participant

    As I understand it Steinberg no longer make vst2 sdk licenses available to developers. Therefore no new developers will be able to release vst2 versions of plugins.

    #40643

    tomx2188
    Participant

    Happy to hear it’s on the radar! 🙂

    Yes, it seems there was a change regarding licensing from Steinbergs side.
    I came across this info when checking out Odin 2, a fairly new and pretty capable free synth, which isn’t available as VST2 for that reason.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

© 2020 Zynewave